Categorie: Cisco
Cisco 819-LTE (KPN 4G/LTE)
Werkende config voor een Cisco 819-4G (LTE) en KPN mobiel.
Begin met het instellen van het Celluar modem, dit moet direct in de enable modus nog niet in de configure modus (dus niet conf t).
Stel regio in op Europe:
cellular 0 lte prl-region 1
Optioneel, stel in op alleen LTE modus:
cellular 0 lte technology lte
Activeer de SIM (waarbij de XYZ de SIM pincode is):
cellular 0 lte sim unlock XYZ
Controle:
Locked
Router#sh cellular 0 security Active SIM = 0 SIM switchover attempts = 0 Card Holder Verification (CHV1) = Enabled SIM Status = Locked SIM User Operation Required = Enter CHV1 Number of CHV1 Retries remaining = 3
Unlocked:
Router#sh cellular 0 security Active SIM = 0 SIM switchover attempts = 0 Card Holder Verification (CHV1) = Disabled SIM Status = OK SIM User Operation Required = None Number of CHV1 Retries remaining = 3
Controle of de sim verbonden is met het mobiele netwerk, stuur een SMS;
cellular 0 lte sms send 061234567 hallo
Maak een profile voor de data APN:
cellular 0 lte profile create 1 create KPN4G.nl none
Profile 1 is standaard gekoppeld aan Celluar 0 en word aangesproken als de radio up is.
Om te controleren of de radio en de SIM is aangemeld:
sh celluar 0 radio 4G#sh cellular 0 radio Radio power mode = ON Channel Number = 6400 Current Band = LTE Current RSSI = -80 dBm Current RSRP = -100 dBm Current RSRQ = -4 dB Current SNR = 14.6 dB Radio Access Technology(RAT) Preference = LTE Radio Access Technology(RAT) Selected = LTE
En om te controleren of de radio het netwerk correct ziet:
sh cellular 0 network 4G#sh cellular 0 network
Current System Time = Sun Jan 6 0:13:57 1980 Current Service Status = Normal Current Service = Packet switched Current Roaming Status = Home Network Selection Mode = Automatic Network = KPN Mobile Country Code (MCC) = 204 Mobile Network Code (MNC) = 8 Packet switch domain(PS) state = Attached Registration state(EMM) = Registered Tracking Area Code (TAC) = 60501 Cell ID = 9574667
Onderstaand de IOS configuratie waarbij de interface vlan 1 als interne interface gebruikt word met NAT en ip reeks 192.0.200.0/24.
!
controller Cellular 0
lte sim authenticate 0 0000
lte sim data-profile 1 attach-profile 1 slot 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 60
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
interface Cellular0
ip address negotiated
no ip unreachables
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer enable-timeout 60
dialer string lte
async mode interactive
routing dynamic
!
interface Vlan1
ip address 192.0.200.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip nat inside source list NAT interface Cellular 0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
ip access-list extended NAT
permit ip 192.0.200.0 0.0.0.255 any
!
line 3
script dialer lte
modem InOut
no exec
transport input telnet
transport output all
rxspeed 100000000
txspeed 50000000
Achtergrond info
http://blog.martinshouse.com/2014/09/in-hope-that-it-helps-others-here-is.html
Cisco Guide to Harden Cisco IOS Devices
http://www.cisco.com/c/en/us/support/docs/ip/access-lists/13608-21.html
http://tools.cisco.com/security/center/viewAMBAlert.x?alertId=36857
IOS XR primer
And of course, the Master Command Listing for IOS XR was
very helpful too.
Once you have all this down, you can then dig into specific
topics such as RPL, e.t.c.
Here is a good one on RPL.
gives a baseline with some good info as to differences
and then move on to
http://www.cisco.com/c/en/us/support/ios-nx-os-software/ios-xr-software/products-installation-and-configuration-guides-list.html
which gives the in depth topic by topic.
https://supportforums.cisco.com/community/5996/xr-os-and-platforms
Document tab as well as Blog tab will get you expert at IOS-XR in no time.
ciscolive.com pop “IOS-XR” into the search
Synchronization & Timing Self-Paced Online Bootcamp (Available Now)
– Industrial Solutions: More efficient Manufacturing
– Smart Grid: Replacing legacy Time Distribution with Ethernet
– High Frequency Trading: Regulatory and Market Differentiation
However this topic is being perceived as complex especially if your core expertise is IP networking. Dennis Hagarty from Cisco Systems who is also an industry expert in this area, decided to solve this problem by developing “Synchronization & Timing Self-Paced Bootcamp” which covers technology fundamentals as well as configuration and verification. Complete bootcamp is available on Youtube and has three modules. Below are the Youtube links,
Synchronization & Timing Self-Paced Bootcamp
Playlist: http://youtu.be/N7nTCHxBitU?
Clocking & Sync Part 1/3: TDM and Packet-based Frequency Sync
http://youtu.be/N7nTCHxBitU?
Clocking & Sync Part 2/3: IEEE 1588 and PTPv2
http://youtu.be/250reOmrN70?
Clocking & Sync Part 3/3: Configuration of Clocking and Timing
http://youtu.be/eitxR-_lMxs?
Cisco IOS XR EEM
Hi , I have the below EEM script and am trying to do it using IOS XR
event
manager applet SLA_OUT
event snmp oid 1.3.6.1.4.1.9.9.42.1.2.9.1.6.2 get-type exact entry-op eq entry-val 1 exit-op eq exit-val 2 poll-interval 5
action 1.0 syslog msg “Test”
action 1.1 cli command “enable”
action 1.2 cli command “configure
terminal”
action 1.3 cli command “ip route 0.0.0.0
0.0.0.0 192.168.13.3”
action 1.4 syslog msg “There is a problem on our Primary connection , move all the traffic to the Secondary Line”
event
manager applet SLA_OK
event snmp oid 1.3.6.1.4.1.9.9.42.1.2.9.1.6.2 get-type exact entry-op eq entry-val 2 exit-op eq exit-val 1 poll-interval 5
action 1.0 syslog msg “OK”
action 1.1 cli command “enable”
action 1.2 cli command “configure
terminal”
action 1.3 cli command “no ip route
0.0.0.0 0.0.0.0 192.168.13.3”
action 1.4 syslog msg “Our Primary
connection is functionin again , stop using the Secondary Line”
Carrier Ethernet and Mobile Backhaul Video Tutorials
Carrier Ethernet and Mobile Backhaul Video Tutorials
Cisco has posted Ten New video tutorials on “Carrier Ethernet and Mobile Backhaul” on Cisco SPAG youtube channel.
Link:
http://youtu.be/uKwuge9DQl8?
Topics:
Introduction to ELINE Services
Configuring ELINE Services
Configuring CFNM on ELINE Service
Configuring Two Way Delay Measurement using Y1731PM Introduction to ELAN Services Configuring G8032 in an Access Ring Network Introduction to MPLS in Access Configuring ELAN Service using H-VPLS BGP Auto Discovery Configuring CE2.0 Layer 2 Protocol Forwarding Configuring Unified MPLS Transport
Cisco SPAG Youtube Channel
https://www.youtube.com/
ME3600 does not automatically copy DSCP into COS
ME3600 does not automatically copy DSCP into COS and also does not automatically copy EXP into COS T-T
Hi all,
I found the problem my customer’s TOS is rewritten.
Topology:
Tester1 (Send CoS=5) — Gi0/0/1/0 ASR9k 0/0/1/0.3604 — xconnect — Gi0/9 ME-3600X Gi0/24 — Gi0/14 ME-3400 Gi0/5 — Tester2 (rx CoS=0)
I open the TAC both ASR and ME Switch Team and this is the answer from ME Switch Team:
ME3600 does not automatically copy DSCP into COS and also does not automatically copy EXP into COS as described in the following document which was presented on Cisco Live event (page 44 and 45):
http://d2zmdbbm9feqrf.
Solution:
Please configure policy-map on interfaces to set a proper COS value basing on incoming DSCP.
ASR1000 BGP advertise best-external
>> clients? That is nonsense!
>> > Why XR doesn’t have any problems with that?
>> > From a business point of view I understand it very well as you need
>>to buy
>> 4 instead of two routers but otherwise…
>>
>> i don’t use this feature, but the docs say it’s supported on RRs from
>>3.4S.
>>
>> Nick
>>
>Well yes it is but actually only for nonclients as one can’t advertise
>best external to a RR client.
>So if there’s a PE that happens to be a route reflector as well, then
>this feature is useless.
>On XR there’s no such limitation.
A RR needs to advertise the best path to each RR client, that’s its job.
If it should also send the best-external (which would be, by definition,
not the overall best path) to the clients, you need to use add-path as you
need to advertise more than one path. Have you enabled both? can you share
the config?
IIRC this is the same on XR, you also need to enable add-path on the RR..
Strange IOS as DHCP Client behevior
>
> 10.2.2.140 0063.6973.636f.2d30. Dec 20 2014 11:44 AM
> Automatic
> 3035.302e.3536.6138.
> 2e34.6132.622d.4769.
> 302f.30
>
> Do you have idea why MAC is so weird ? Rest clients – Eg. Linux or Window
> boxes MACs is displayed correctly.
It’s not a MAC address, it’s a client identifier. And IOS by default
chooses a text string as client identifier. In your case it’s:
“cisco-0050.56a8.4a2b-Gi0/0”
> Anything to configure at Cisco clients to have proper MAC in binding
> database ?
The above example is completely proper. I’m not aware of any method for
making IOS not use a client identifier, but you can change the
identifier it sends via e.g. “ip dhcp client client-id …” interface
command.