! Enable L2TP
! - Connect VPN clients to VRF private
! Must use "password" ("secret" won't work)
username roadwarrior password 0 <removed>
aaa authentication ppp l2tp-auth local-case
ip local pool l2tp-pool 10.1.11.100 10.1.11.199
vpdn enable
interface Virtual-Template1
ip unnumbered Loopback0
peer default ip address pool l2tp-pool
ppp mtu adaptive
ppp authentication ms-chap-v2 l2tp-auth
!
vpdn-group l2tp-group
! Default L2TP VPDN group
description L2TP clients
accept-dialin
protocol l2tp
virtual-template 1
!
no l2tp tunnel authentication
!
! ISAKMP policy:
! - OS X offers aes 256 and 128 (but not 192)
! - SHA1 is the default hash on Cisco IOS (does not show up in config)
! - OS X doesn't offer any of the PFS groups
crypto isakmp policy 50
encr aes 256
authentication pre-share
group 2
lifetime 14400
!
! Internet is connected to VRF cable
crypto keyring l2tp-ring vrf cable
pre-shared-key address 0.0.0.0 0.0.0.0 key <removed>
!
! IPsec policy
! - Match OS X proposal
crypto ipsec transform-set l2tp-transform esp-aes 256 esp-sha-hmac
mode transport
!
! Require IPsec for all L2TP traffic
!
ip access-list extended l2tp-access
permit udp any eq 1701 any
!
crypto dynamic-map l2tp-map 10
set nat demux
set transform-set l2tp-transform
match address l2tp-access
!
crypto map l2tp 10 ipsec-isakmp dynamic l2tp-map
interface Vlan6
crypto map l2tp
!
Netflow – FNF cheat sheet
Here’s a quick basic FNF (from ASR 1000):
flow exporter PRIMARY_NMS
description FNF export to Primary NMS
destination 192.168.100.100
source Loopback0
transport udp 9996
template data timeout 60
!
flow monitor MONITOR_V4
description IPv4 netflow monitor
record netflow ipv4 original-input
exporter PRIMARY_NMS
cache timeout active 900
cache entries 200000
!
flow monitor MONITOR_V6
description IPv6 netflow monitor
record netflow ipv6 original-input
exporter PRIMARY_NMS
cache timeout active 900
cache entries 200000
!
!For each interface ....
!
interface GigabitEthernet0/0/0
ip flow monitor MONITOR_V4 input
ipv6 flow monitor MONITOR_V6 input
!
interface GigabitEthernet1/0/0
ip flow monitor MONITOR_V4 input
ipv6 flow monitor MONITOR_V6 input